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Chapter 1
Introduction
The CyberOptics Semiconductor WaferSense™ Auto Leveling Sensor (ALS) uses electronic 
inclinometer technology, with accuracy equal to or better than ± 0.03 degree, over a range of 
-4° to +4°, permitting more precise and efficient leveling adjustments than possible with the 
human eye or traditional bubble levels. The two-dimensional bubble-level display in the 
LevelView™ software application makes it easy to precisely adjust equipment. The large display 
and wireless link let you place the computer at a convenient distance from the sensor.

ALS consists of the following components:
• Leveling sensor. The sensor is designed with a wafer-like form factor, so it can fit in 

most wafer-handling equipment. The sensor package is also vacuum compatible.
• LevelView software. The LevelView software application monitors the sensor and 

displays inclination angle and other status information in real time. LevelView runs on 
most personal computers that use the Microsoft Windows operating system.

• Wireless link. The LevelView software communicates with the sensor by using a 
Bluetooth (certification pending) wireless link that attaches to a USB port on a 
personal computer. 

• Sensor charging case. The sensor is powered by an internal rechargeable battery, 
which you recharge by placing the sensor into the charging case.

• Carrying case. The carrying case makes it easy to take your complete ALS system 
with you in the plant or on the road.

The following chapter gives you instructions for installing your ALS system.
1.1



Chapter 2
Installing Your ALS
This chapter describes the procedures you need to perform to install your ALS and get it ready 
for use. For best results, perform the procedures in the order they are presented in this chapter:

1. Installing the software
2. Installing the wireless link on the USB port
3. Checking the link to the sensor
4. Registering your sensor
5. Running the LevelView application

Installing the Software
To run the WaferSense ALS software, your computer must have the following:

• Windows 98 Second Edition, Windows 2000, Windows Me, or Windows XP 
operating system

• One free high-power USB 1.1 or USB 2.0 port

To install the WaferSense ALS software:

1. Log on using an account with Administrator privileges. (If you are using Windows 98 or 
Windows Me, there is no separate Administrator account, and you can install as any user.)

Caution
Dropping the sensor or hitting it against a hard object can bend it, damage the internal
components, or knock it out of calibration. While it is not as fragile as an actual silicon
wafer, handle the sensor with care, as you would any precision instrument. If the sensor is
damaged or in need of calibration, see Chapter 4, “Maintaining Your ALS.”
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Chapter 2  Installing Your ALS
2. Insert the WaferSense ALS Installation Disk into the CD Drive.
The InstallShield Wizard starts automatically, as shown in Figure 2.1. If the wizard doesn’t 
start automatically, use Windows Explorer to view the contents of the CD and double-
click the setup.exe program. 

Figure 2.1: The InstallShield Wizard
3. Follow the instructions provided by the wizard to install the software.
4. After you complete the instructions for all of the wizard screens, click Finish. If 

Windows notifies you that the drivers have not passed Windows logo testing, just click 
Continue Anyway to complete the installation.

By default, the Setup program installs the LevelView application in a new program group called 
WaferSense ALS. Setup also installs an online copy of this user’s guide, which is available from 
the LevelView Help menu and in the WaferSense ALS program group in the Windows 
Start menu.
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Installing Your ALS  Chapter 2
Installing the Wireless Link
To install the wireless link:

1. Turn on your computer.
2. Locate an unused, high-power USB port on your computer. The ALS wireless link 

module requires a high-power USB port, such as the built-in ports on your computer and 
ports on USB hubs that have power cords. Unpowered USB hubs won’t work.

3. The USB cable provided with your ALS has a different plug on each end. Locate the end 
with the plug that matches the USB port on your computer and plug the cable into 
the port.

4. Plug the other end of the cable into the link module. 
The Windows operating system recognizes the new link module hardware and displays 
the Found New Hardware Wizard, as shown in Figure 2.2. 

Figure 2.2: Found New Hardware Wizard
5. Click Install the software automatically and click Next.

If you already installed the WaferSense ALS software (see “Installing the Software,” on 
page 2.1), Windows will automatically find the drivers. If not, the drivers are located in the 
Utilities folder on the installation CD-ROM.

6. After you complete the instructions for all of the wizard screens, click Finish.
The Power light on the module turns on indicating that the module is getting power from 
the USB port. Ignore the Pair Status and Connection Status lights for now.
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Chapter 2  Installing Your ALS
Checking the Link to the Sensor
To complete the installation, verify that the sensor and link can communicate as follows:

1. The sensor operates from an internal rechargeable battery. Before using the sensor for the 
first time, charge it for two hours. For information on checking the charge on the battery 
and the procedure for recharging, see “Using the Rechargeable Battery,” on page 3.18.

2. Remove the sensor from the charging case and press the ON OFF button to turn on 
the sensor.
The Power light on the sensor turns on.

3. Verify that the Pair Status lights on both the sensor and link module are on. If either 
light is not on, your sensor and link might not be paired with each other. To reset the 
pairing, see “Changing the Pairing Between the Sensor and Link,” on page 3.20. 

4. Immediately after turning on the sensor, the Connection Status lights on the sensor and 
link will blink slowly. After a few seconds the sensor and link will connect and both lights 
will be on and no longer blinking. If the lights continue to blink, see “Monitoring the 
Wireless Connection to the Sensor,” on page 3.19.

5. After starting the LevelView application (see “Running the LevelView Application,” on 
page 2.5), you can verify the connection to the sensor by comparing the serial number 
printed on the sensor to the serial number shown in the About LevelView dialog, which is 
available in the LevelView application by choosing the Help > About menu item.

That completes the installation of your ALS.

Registering Your Sensor for Calibration Service
Your WaferSense ALS needs to be returned to CyberOptics Semiconductor for calibration and 
battery replacement every 12 months to perform at specified accuracy. The battery is not user 
replaceable; replacement must be performed at the factory. The LevelView application (see 
“Running the LevelView Application,” on page 2.5), prompts you to register your sensor for 
calibration. Registering allows you to schedule your sensor’s calibration at a time that is most 
convenient for you and to expedite its return. You must have a valid service contract for 
calibration and service.

You can register your sensor in any of the following ways:
• On the Internet: www.CyberopticsSemi.com/calibrate
• By phone: 800-366-9131 (US and Canada only)
• By faxing the WaferSense ALS Calibration Registration to: (503) 495-2201
• By sending an e-mail message containing the information specified on the WaferSense 

ALS Calibration Registration to: ALScalibrate@cyberoptics.com.
2.4
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Installing Your ALS  Chapter 2
Running the LevelView Application
To start the LevelView application:

• From the Windows Start menu, choose WaferSense ALS > LevelView.

The LevelView application starts, and the sensor and PC exchange information, as 
shown in Figure 2.3.

Figure 2.3: Starting the LevelView Application
Initializing communications usually takes less than 10 seconds. For information on using 
LevelView, see “Chapter 3, Using Your ALS.”
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Technical Support
CyberOptics Semiconductor offers free technical support to customers. If the ALS hardware or 
the LevelView software appear to be malfunctioning, please contact us, and we’ll be happy to 
assist you.

When you contact us, please make sure that you have the following information available:
• A detailed description of the problem you are having, including the exact text of any 

error messages and a list of steps to reproduce the problem.
• The operating system running on your computer.
• Information about your computer, including manufacturer, CPU type, and 

memory size.
• The serial number of your sensor and the version of the LevelView application. The 

serial number of the sensor is printed on a label on the top of the sensor. The 
software version (and the sensor serial number) are available in the LevelView 
application by choosing the Help > About menu item.

Figure 2.4: The About LevelView Dialog
Technical support is available Monday through Friday, 8:00 A.M. to 5:00 P.M. Pacific Time.

• Voice: (503) 495-2200
• Toll free: 800-366-9131 (US and Canada only)
• Fax: (503) 495-2201
• E-mail: CSsupport@cyberoptics.com
• Internet: www.CyberopticsSemi.com
2.6
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Chapter 3
Using Your ALS
This chapter gives you instructions for performing the following tasks with the ALS:

• Using the ALS sensor buttons and indicators
• Performing a basic inclination measurement
• Setting the stabilization criteria for inclination readings
• Setting the Go/No Go tolerance
• Specifying a reference plane
• Monitoring the operating temperature
• Logging your readings
• Printing the LevelView window
• Using the rechargeable battery
• Monitoring the connection between the sensor and link module
• Changing the pairing between the sensor and link module.
• Saving your settings
3.1



Chapter 3  Using Your ALS
Using the ALS Sensor Buttons and Status 
Lights

ALS sensors have two buttons:
• ON OFF. Turns the sensor on and off. If the sensor suffers an electrostatic 

discharge at the center charging contact, the sensor might stop responding, even 
though it is turned on. To restore the sensor to normal operation, turn the sensor off 
and then on again.

• NEW PAIR. Changes the pairing between a sensor and a link (see “Changing the 
Pairing Between the Sensor and Link,” on page 3.20).

ALS sensors also have the following status lights:
• Power. Glows red while the sensor is turned on. Blinks slowly when the battery 

power is at approximately 10% or less.
• Charging. Glows red when the sensor is being charged in the charging case.
• Charging Done. Glows red when the battery has reached at least 90% of full charge.
• Connection Status. Glows red when the sensor has established communication with 

the link. Blinks slowly while the sensor is trying to establish a connection with the 
link.

• Pair Status. Glows red when the sensor is paired with a link (see “Changing the 
Pairing Between the Sensor and Link,” on page 3.20). 
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Performing a Basic Inclination Measurement
LevelView shows the angle of inclination of the sensor using two types of readouts 
(see Figure 3.1):

• Graphical readouts that mimic bubble levels
• Numeric readouts that show inclination in two dimensions

LevelView updates the readings several times per second, so you see any changes in real time. 

Figure 3.1: The LevelView Application
To perform a basic inclination measurement:

1. Make sure the computer running the LevelView application is within the range of the link 
module, about 30 ft (10 m).

Numeric Roll and 
Pitch Readouts

Left Bubble Display Right Bubble Display
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Chapter 3  Using Your ALS
2. The ALS200 and ALS300 sensors have an alignment notch in the edge similar to the 
notch in the edge of a wafer. The ALS150 sensor has a flat side for alignment. Place the 
sensor on the equipment you want to check, noting the alignment of the notch or 
flat side.
When you move the sensor, the roll and pitch readings typically need a few seconds to 
stabilize. The bubble displays and Roll and Pitch readouts are shaded during this 
stabilization period, and a message in the left bubble display counts down the seconds, as 
shown in Figure 3.2. Whenever the sensor detects pitch or roll movement, LevelView 
restarts the stabilization countdown. You can set the length of the stabilization period and 
the sensitivity that triggers the countdown (see “Setting the Stabilization Criteria,” on 
page 3.7). 

Figure 3.2: Stabilizing the Reading

Countdown for 
stabilizing the readings
3.4



Using Your ALS  Chapter 3
3. The Roll and Pitch readouts and bubble displays indicate the inclination of the sensor:
• The Roll and Pitch readouts (see Figure 3.3) indicate the number of degrees of 

inclination, to 100ths of a degree, in two dimensions. Assuming the notch (flat side on 
the ALS150) is in the edge of the sensor closest to you, Roll indicates side-to-side tilt, 
and Pitch indicates front-to-back tilt. If the front edge is higher than the back or the 
right edge is higher than the left, the readings are positive. Readings outside the 
working range of the sensor are displayed as ####. 

Figure 3.3: Numeric Pitch and Roll Readouts
For information on the accuracy of the readings, see “Precision and Accuracy,” on page 5.1.

+

-
Roll

Pitch

+

-
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Chapter 3  Using Your ALS
• The bubble level displays (see Figure 3.4) show the inclination graphically in real 
time. In both bubble displays, the solid green circle represents the bubble. The red 
circle indicates the Go/No Go setting, which you can adjust (see “Setting the Go/No 
Go Tolerance,” on page 3.8). In the left bubble display, the outside edge of the display 
area represents the maximum inclination reading, which is four degrees in all 
directions. The bubble level display on the right is a magnified view showing just the 
area within the dashed square of the left bubble display.

Figure 3.4: Bubble Level Displays

Alignment Marks
The notch in the edge of the ALS200 and ALS300 sensors and the flat side on the ALS150 
sensor serve as alignment marks for placing the sensors into wafer-handling equipment. These 
alignment marks also help you relate the bubble level displays to the orientation of the sensor. 

In some cases you might need to place the sensor into equipment with the notch or flat side 
turned away from you. This can make it more difficult to relate the bubble level displays to the 
orientation of the sensor. For this reason, the sensors have additional alignment marks on the 
vertical surface of the sensor near the edge. These marks consist of one to four vertical lines (|, 
||, |||, or ||||) located at 0°, 90°, 180°, and 270° relative to the notch or flat side. 

Alignment Notch Bubbles

Go/No Go Circles
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Setting the Stabilization Criteria
When the sensor detects motion in pitch or roll, the LevelView application displays a 
countdown timer to indicate that the readings need time to stabilize (see Figure 3.2 on 
page 3.4). The length of time that the readings need to stabilize depends on the operating 
conditions and your required tolerance for stability. The default stabilization time (20 seconds) 
and stabilization sensitivity (0.01 degrees) provide for the maximum stability. When making 
rough measurements and adjustments, adjusting these settings lets you work more quickly.

To specify the stabilization criteria:

1. Choose the menu item Settings > Set Stabilization Criteria. This menu item is 
unavailable when LevelView is set to display readings from a log file (see “Displaying 
Readings from a Log File,” on page 3.16).
The Set Stabilization Criteria dialog is displayed, as shown in Figure 3.5.

Figure 3.5: Set Stabilization Criteria Dialog
2. In the Stabilization time list, choose the number of seconds you want LevelView to 

pause to allow readings to stabilize, or click Use Default to reset the time to the default 
20 seconds. 

3. In the Stabilization sensitivity list, choose the fraction of a degree in pitch or roll 
movement that you want to trigger LevelView to restart the stabilization counter. To reset 
the value to the default, click Use Default to reset the sensitivity to 0.01 degree.

4. Click OK.
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Chapter 3  Using Your ALS
Setting the Go/No Go Tolerance
The Go/No Go tolerance sets the diameter of the red circle in the bubble displays. This circle 
makes it easy to see when you have leveled a piece of equipment to within an acceptable 
tolerance. When the center of the bubble is within the Go/No Go circle, the bubble is green, 
indicating that the reading is within your specified tolerance. When the center of the bubble 
reaches or passes the edge of the Go/No Go circle, the bubble changes to red to indicate the 
reading exceeds your specified tolerance. 

Figure 3.6: The Go/No Go Tolerance
To change the Go/No Go value:

1. Choose the menu item Settings > Set Go/No Go Tolerance.
The Set Go/No Go Tolerance dialog is displayed, as shown in Figure 3.7.

Figure 3.7: Set Go/No Go Tolerance Dialog

Go/No Go Circle

Out of Tolerance

In Tolerance
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2. Specify the New Go/No Go tolerance and click OK.

You can set the tolerance to any value in the range 0.05 to 3.9 degrees. However, if you are 
using a reference plane (see “Specifying a Reference Plane,” on page 3.10), the maximum value 
is less than 3.9 degrees. You can’t set a tolerance that would extend the Go/No Go circle 
beyond the edge of the left bubble display area. If you try to set a value that is too large, 
LevelView will change the value to the maximum. 

Note
The radius of the bubble in the left bubble display is about 0.25 degree. If you set
the Go/No Go tolerance to less than this amount the red circle in the left bubble
display will be completely covered by the bubble when the bubble is centered.
The right bubble display will still show the bubble and the Go/No Go circle.
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Specifying a Reference Plane
By default, the sensor indicates absolute degrees of inclination, which is relative to a plane 
perpendicular to the direction of the earth’s gravitational force. You can specify a different 
reference plane, and the sensor will indicate degrees of inclination relative to that plane. 

To specify a reference plane:

1. Place the sensor on the surface that you want to use as your reference plane.
2. Choose the menu item Settings > Set Reference Plane. This menu item is unavailable 

when LevelView is set to display readings from a log file (see “Displaying Readings from a 
Log File,” on page 3.16). 

The sensor takes the current absolute inclination readings as offsets to the new 
relative plane. The offsets are displayed in the Reference Plane readouts 
(see Figure 3.8). 

Figure 3.8: Specifying a Reference Plane
3. Select the Relative to option above the Reference Plane readouts.

You can switch the sensor between indicating absolute and relative inclination by clicking the 
corresponding option button (see Figure 3.8). Switching between Absolute and Relative to 
does not affect the current offsets for the reference plane inclination angles; LevelView retains 
the last offsets until you change them.
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When you specify a reference plane and set LevelView to display Relative to that plane, the 
coordinate axes of the left bubble display shift within the display area, as shown in Figure 3.9.    

Figure 3.9: Left bubble Display with a Reference Plane
This shift in the axes reflects the fixed range of the sensor relative to absolute level. The sensor 
has a range of -4° to +4° from absolute level. If you set a reference plane at 
-2° absolute pitch, the range of the sensor relative to that reference plane is -2° to +6° pitch. 
Shifting the center of the bubble display to the left accurately represents the new range of the 
sensor relative to the reference plane.
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Monitoring the Operating Temperature
The operating range for the sensor to achieve the specified accuracy for inclination readings is 
20 °C - 30 °C. The Temperature monitor in the LevelView window (see Figure 3.10) shows 
the current operating temperature with a numeric readout and a thermometer graphic. 

Figure 3.10: Temperature Monitoring Gauge
The thermometer indicates the upper and lower limits of the operating temperature range. The 
bar changes color as an additional indication of where the current temperature is relative to the 
accurate operating range:

• Blue. Less than 20 °C the sensor is operating below the range where it produces 
accurate readings.

• Green. 20 °C to 30 °C the sensor is operating in its normal temperature range, where 
it produces readings meeting the specified accuracy.

• Orange. Greater than 30 °C to 60 °C the sensor is operating above the range where it 
produces accurate readings, but not so hot that the sensor will be damaged.

• Red. Greater than 60 °C the sensor is operating at a temperature so high that it might 
be damaged.

OK
20-30 °C

High
>30-60 °C

Too High
>60 °C

Low
< 20 °C
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Logging Your Readings
LevelView can keep a record of your activities as you use the sensor to check the inclination of 
various pieces of equipment. LevelView keeps the record in a log file, using a comma-separated 
values (CSV) text format. Files in CSV text format are easy to import into spreadsheet and 
word processing programs. You can specify the log file path (see “Changing the Log File,” on 
page 3.15). The log file contains the following information for each log file entry:

• Date and Time. The date and time of the log file entry (see “Working in a Different 
Time Zone,” on page 3.15).

• Displayed Roll and Pitch. The roll and pitch values displayed in the Readings text 
boxes (see “Performing a Basic Inclination Measurement,” on page 3.3). These values 
can be either absolute or relative to a reference plane (see Absolute/Relative below).

• Roll and Pitch Reading. The absolute roll and pitch values. When the reference 
plane is set to Absolute, these values are identical to the Displayed Roll and 
Pitch values.

• Roll and Pitch Reference. Current offsets for the reference plane (see “Specifying a 
Reference Plane,” on page 3.10).

• Roll and Pitch Stable. Whether the roll and pitch readings were Stable or Unstable 
when logged (“Setting the Stabilization Criteria,” on page 3.7). Readings are logged as 
Unstable when they are logged while the stabilization countdown timer is still 
counting down.

• Stabilization Time. The current setting for stabilization time (“Setting the 
Stabilization Criteria,” on page 3.7).

• Roll and Pitch Stable Time. Elapsed time since the last stabilization countdown 
started (“Setting the Stabilization Criteria,” on page 3.7). If a logged reading is Stable, 
this number will be equal to the value for stabilization time.

• Go/No Go Value. The tolerance setting for the bubble displays (see “Setting the 
Go/No Go Tolerance,” on page 3.8).

• Absolute/Relative. The current selection for the reference plane (see “Specifying a 
Reference Plane,” on page 3.10).

• Temperature Reading. The current operating temperature (see “Monitoring the 
Operating Temperature,” on page 3.12).

• Battery Time. The percentage of time remaining before the battery must be 
recharged (see “Using the Rechargeable Battery,” on page 3.18).

• Serial Number. The serial number of the sensor.
• Operator, Tool, Station, and Comment. Text fields you can use to record your own 

information with each log entry (see “Including User-Specified Information in the 
Log File,” on page 3.15). 
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The values for all roll and pitch readings and the Go/No Go setting are displayed to 
two decimal places but written to the log file to three decimal places.

Figure 3.11 shows the logging controls in the LevelView window.

Figure 3.11: Logging Controls
The remainder of this section tells you how to:

• Use automatic or manual logging
• Adjust the date and time for working in different time zones
• Specify a different location or file name for the log file
• Display a past reading from a log file

Automatic and Manual Logging
LevelView can post entries to the log file both automatically and on your command.

To post an entry to the log file manually:
• In the main LevelView window, click Log a Reading Now (see Figure 3.11).

LevelView immediately writes a log entry each time you click the button.

To have LevelView post log entries automatically:

1. Using the automatic logging controls in the main LevelView window (see Figure 3.11), 
specify a logging interval.

2. Check the box to activate automatic logging.

LevelView automatically writes a log entry at the end of each time interval. To turn off 
automatic logging, clear the check box.

Manual Logging

Automatic Logging

Total Log Entries

Log File Name

View Sensor or Log

User-Specified
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You can use either automatic or manual logging, or both at the same time. If you have 
automatic logging turned on, clicking Log a Reading Now immediately adds an entry to the 
log file, in addition to the entries being logged automatically.

Including User-Specified Information in the Log File
Operator, Tool, Station, and Comment are text fields you can use to record your own 
information with each log entry to help identify the inclination test you are running. You can fill 
in any text information you want in these fields.

To include user-specified information for logging:
• Type your text into the Operator, Tool, Station, and Comment text fields.

You can change or delete this information at any time for future log entries. To quickly clear all 
of the fields, click Clear All.

Working in a Different Time Zone
The main LevelView window shows the current date and time, which are used to timestamp 
entries for the log file. The date and time values are taken from the system clock of the 
computer. If you need to work in a different time zone temporarily, you don’t need to change 
your system clock. You can have LevelView log the correct local time for the new location, by 
specifying a time offset. LevelView adds your time offset to the time from the system clock and 
uses the result in the Date and Time fields in the main window and for the timestamp in the 
log file.

To set a time offset:

1. Choose the Settings > Set Time Offset menu item. This menu item is unavailable when 
LevelView is set to display readings from a log file (see “Displaying Readings from a Log 
File,” on page 3.16).

2. In the Set Time Offset dialog, enter the time difference between your normal location 
and your temporary location in hours and minutes using the corresponding list boxes, and 
click OK.

Changing the Log File
By default, LevelView writes log entries to the file My Documents\ALS Files\ALS 
Readings.csv. If you prefer, you can specify a different log file.

To change the log file: 

1. Choose the File > Select Log File menu item.
2. In the ALS Log File dialog, specify the folder and file name for the log file, and 

click Save.
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Displaying Readings from a Log File
Normally, LevelView displays real-time readings transmitted from the sensor. However, you 
can also have LevelView display a previous entry from a log file.

To display a reading from a log file:

1. Click View Entries in Log File (see Figure 3.12). 
The label on the button you just clicked changes to Display Readings from Sensor, the 
Connection indicator changes to an icon of a page and now says Viewing log file, and 
the controls for automatic and manual logging are replaced by a list of the entries in the 
log file. 

Figure 3.12: Displaying a Reading from a Log File
2. From the list of entries in the log file, choose the entry you want to display. 

LevelView displays the readings for the selected entry from the log file, except for the 
Go/No Go reading. The Go/No Go control remains active, so that you can view the 
reading from the log file using different go/no go tolerances. Automatic logging is 
suspended while you are displaying readings from a log file.

3. When you are done viewing past readings from the log file, click Display Readings from 
Sensor, so that LevelView returns to displaying sensor readings in real time.

To display a reading from a different log file, see “Changing the Log File,” on page 3.15.

Log File Name List of Log File EntriesView Sensor or Log
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Printing the LevelView Window
You can print an image of the LevelView window to have a graphical record of the session. 

To print an image of the LevelView window:

1. Choose File > Print.
2. In the Print dialog, click OK.

You can also select a printer other than the default and change the printer setup, or see a 
preview of what LevelView will print:

• To select a different printer, change the paper selection or print orientation, or set 
printer properties, choose the File > Print Setup menu item. 

• To see a preview of what LevelView will print, choose the File > Print Preview 
menu item.
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Using the Rechargeable Battery
The sensor operates from an internal rechargeable battery. From a full charge, the battery 
provides about six hours of continuous use. Before using your sensor for the first time, charge 
it for two hours.

The battery can be recharged about 500 times before the charge life starts to degrade 
significantly. The battery is not user replaceable. For information on replacing the battery, see 
“Annual Factory Calibration and Battery Replacement,” on page 4.1.

Monitoring the Battery Level
LevelView receives frequent updates from the sensor on the state of the sensor’s battery. The 
Battery indicator in the LevelView window shows the approximate percentage of operating 
time remaining before you must charge the battery. 

Figure 3.13: Battery Monitor

Charging the Battery
To charge the sensor’s battery:

1. Place the sensor in the charging case and close the lid. You don’t need to align the sensor 
in any particular orientation in the case.

2. Plug the charger line adapter into a 100 VAC to 240 VAC supply and plug the other end 
into the charging case.
The Charging light is on while the sensor is charging.

3. Charge the sensor until the Charging Done light turns on or until you need to use the 
sensor (you don’t need to wait until the sensor is fully charged).
Fully charging the battery takes about two hours. Charging for one hour charges the 
battery to about 80% of its capacity. You can leave the sensor in the charging case when 
not in use; the battery won’t overcharge. 
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Monitoring the Wireless Connection to 
the Sensor

The LevelView application communicates with the sensor by using a Bluetooth wireless link. 
The wireless link has a range of about 30 ft (10 m). 

The Connection indicator in the LevelView window shows the quality of the wireless 
connection between the sensor and the link module. In the traffic signal graphic indicator, the 
large colored circle shows the current signal quality (see Figure 3.14):

• Green. The connection between the link and sensor is good. With a good 
connection, the sensor is sending the maximum number of readings per second to the 
link module (about 6 readings per second). 

• Yellow. There is some interference or other problem with the signal that is preventing 
the link and sensor from communicating at their maximum rate. When the indicator is 
yellow, the readings are still accurate but aren’t being updated as frequently. 

• Red. Indicates that there is no connection between the sensor and link module. The 
values in the display (Pitch and Roll, temperature, battery level, and so on) do not 
update when the indicator is red. 

Figure 3.14: Wireless Connection Monitor
The Bluetooth wireless link technology used in the ALS is a low-power technology that 
operates in the 2.4 GHz radio frequency band. This unlicensed band is also used by many other 
types of devices, such as cordless phones and microwave ovens. Another 2.4 GHz device 
operating in close proximity could interfere with the ALS system. When this happens, 
separating the devices by at least 6 ft (2 m) usually solves the problem.

Other factors can also affect the wireless link, such as the distance between the sensor and link 
and obstacles between the sensor and link that block the signal. If LevelView indicates that the 
connection isn’t good, try moving the computer a few feet closer to the sensor.
3.19



Chapter 3  Using Your ALS
Changing the Pairing Between the Sensor 
and Link

Each sensor is paired with a specific link module at the factory and will operate with only that 
particular link module. However, you can change this pairing, so that you can use your sensor 
with a different link module, or vice versa.

To pair a sensor and link module:

1. If you are changing the pairing of a sensor that is already paired with a link module, first 
unplug the currently paired link module. You can’t pair a sensor with a new link module 
while the currently paired link module is powered on.

2. Make sure the Power lights are illuminated on both the sensor and link module you want 
to pair.

3. On the link module, press and hold the NEW PAIR button until the Pair Status and 
Connection Status lights start to blink rapidly (about four times per second).

4. On the sensor, press and hold the NEW PAIR button until the Pair Status and 
Connection Status lights start to blink rapidly (about four times per second). Then 
release both buttons.
The Pair Status and Connection Status lights will continue to blink until the sensor and 
link have established a new pairing, after which the lights will be on and no longer 
blinking.

Saving Your Settings
Each time you exit the LevelView application, it saves your current settings for the log file, 
automatic logging, reference plane, go/no go tolerance, stabilization criteria, time offsets, and 
user-specified entries in the Windows registry. The next time you start LevelView, it restores 
those saved settings. You can also tell LevelView to save your settings to a file you specify, and 
you can have LevelView read those settings back at any time. This lets you have several 
different configurations for LevelView and be able to switch between them easily, without 
having to reenter the settings.

To save your settings in a file you specify:

1. Choose the File > Save Settings As menu item. This menu item is unavailable when 
LevelView is set to display readings from a log file (see “Displaying Readings from a Log 
File,” on page 3.16).

2. In the ALS Settings File dialog, specify the directory and file name and click Save.
LevelView saves your settings, and the file you specified becomes the current settings file.
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To save your settings in the current settings file:
• Choose the File > Save Settings menu item. This menu item is unavailable when 

LevelView is set to display readings from a log file (see “Displaying Readings from a 
Log File,” on page 3.16).

Each time you start LevelView, the application automatically reads in the most recent settings 
from the Windows registry, including the last settings file you specified, if any. 

Loading Settings from a File
To load settings from a file:

1. Choose the File > Open Settings menu item. This menu item is unavailable when 
LevelView is set to display readings from a log file (see “Displaying Readings from a Log 
File,” on page 3.16).

2. In the ALS Settings File dialog, specify the directory and file name and click Open.
LevelView reads the settings from the specified file and applies the settings. These 
settings are also written to the Windows registry and will be loaded the next time you start 
the LevelView application.
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Maintaining Your ALS
Periodic calibration and battery replacement is the only regular maintenance your ALS requires:

• Annual Calibration and Battery Replacement. Once a year, you should have your 
sensor calibrated and the internal rechargeable battery replaced by returning the 
sensor to the CyberOptics Semiconductor factory.

• Optional Calibration for zero-point drift. If you use absolute level as your 
reference plane, you should calibrate your sensor for zero-point drift at least once 
every two months. You can perform this calibration yourself at your facility.

Annual Factory Calibration and Battery 
Replacement

Every 12 months, you should return your sensor to the CyberOptics Semiconductor factory, 
where we will calibrate the sensor and replace the internal rechargeable battery. You can find 
the date when the sensor was last calibrated at the factory by choosing the Help > About 
LevelView menu item in the LevelView application. 

When the date for calibration approaches, the LevelView application will occasionally notify 
you by displaying the Sensor Calibration Status dialog, as shown in Figure 4.1 on page 4.2.
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Figure 4.1: Sensor Calibration Status Dialog
If you drop the sensor or suspect that it is no longer in calibration, contact CyberOptics 
Semiconductor technical support (see “Technical Support,” on page 2.6).

Battery Use and Disposal
Your ALS sensor contains a lithium-polymer battery. To avoid damage to the sensor, use the 
supplied charger only. Do not charge the sensor at temperatures outside the specified range 
(0 °C to 45 °C). Do not incinerate or dispose of the sensor into fire. Do not immerse the sensor 
when cleaning or spill liquids on the sensor.

For proper battery disposal, please return the sensor to CyberOptics Semiconductor, Inc.:

CyberOptics Semiconductor, Inc.
13555 S.W. Millikan Way
Beaverton, OR 97005

or contact customer support:
• Voice: (503) 495-2200
• Toll free: 800-366-9131 (US and Canada only)
• E-mail: CSsupport@cyberoptics.com
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Optional Calibration for Zero-Point Drift
The zero point of the electronic inclinometers used in the sensor can drift slightly over time. If 
you use absolute level (see “Specifying a Reference Plane,” on page 3.10) as your reference 
plane, you might need to calibrate your sensor for zero-point drift occasionally. You can 
perform this calibration in your own facility by using the calibration routine built into the 
LevelView application. If you work relative to a reference plane other than absolute level, zero-
point drift won’t affect your measurements, and you don’t need to perform this calibration 
procedure.

In the following procedure for calibrating the zero point of the sensor, the software instructs 
you to place the sensor on a flat, level surface. The software takes an inclination reading, 
instructs you to rotate the sensor in place 180 degrees, and then takes a second reading. The 
two readings are used to set the new zero point. It is important that the center of the sensor is 
in the same position on the surface before and after you rotate the sensor. Most surfaces are 
not perfectly flat, so moving the sensor while rotating it can affect the accuracy of the 
calibration. The procedure, therefore, instructs you to place marks on the surface at four points 
around the outside edge of the sensor. You can use these marks to rotate the sensor without 
moving it off center relative to the first calibration reading.

To calibrate your sensor using LevelView:

1. Locate a surface large enough to hold the sensor and having the following characteristics:
• Level to within about 1 degree.
• Stable enough to ensure that the inclination of the surface does not change during the 

procedure.
• Sufficiently smooth and flat that the inclination readings of the sensor don’t change if 

you move the sensor slightly in any direction.
If the surface doesn’t meet these requirements, it might introduce an error in the 
calibration results.

2. Choose the menu item Settings > Calibrate. This menu item is unavailable when 
LevelView is set to display readings from a log file (see “Displaying Readings from a Log 
File,” on page 3.16).

Caution
Performing a zero-point calibration improperly can actually cause the sensor to produce
absolute level readings that are less accurate than readings from the sensor prior to the
zero-point calibration. This is likely to be true if the surface used for the calibration is not
sufficiently stable and flat. To remove a zero-point calibration, run the zero-point
calibration procedure again and click Reset to Factory Default in the first step of the
procedure.
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The Calibration wizard is displayed showing the 1 of 4 Start Calibration dialog, as shown 
in Figure 4.2 on page 4.4.

Figure 4.2: 1 of 4 Start Calibration Dialog
This dialog displays the current calibration values. If you haven’t calibrated the sensor 
since the last factory calibration, both values are zero. Clicking Reset to Factory Default 
changes the calibration values to the values set when the sensor was last calibrated at 
the factory.

3. Click Next to continue with the calibration procedure.
The wizard now displays the 2 of 4 First Calibration Reading dialog, as shown in 
Figure 4.3. 

Figure 4.3: 2 of 4 First Calibration Reading Dialog
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4. This step calls for marking the position of the sensor on the surface. Place a mark on the 
surface next to the edge of the sensor at the notch for the ALS200 or ALS300. For the 
ALS150, place the mark at the scribe mark in the center of the flat side, as shown in 
Figure 4.4.   

Figure 4.4: Marking the Sensor’s Position
5. Place three additional marks on the surface next to the edge of the sensor at the scribe 

marks that are 90°, 180°, and 270° from the notch or flat side. Always mark all 
four positions.

6. Wait for the sensor readings to stabilize and then click Next to take the first 
calibration reading.
After a few seconds, the wizard displays the 3 of 4 Second Calibration Reading dialog, as 
shown in Figure 4.5 on page 4.6.

WAFERSENSE™ ALS150 WAFERSENSE™ ALS200✍

✍

✍

✍ ✍

✍
✍

✍
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Figure 4.5: 3 of 4 Second Calibration Reading Dialog
7. This step applies to the ALS150 only. Set the ALS150 sensor aside. Using a straight-edge, 

extend the top and bottom marks down, as shown in Figure 4.6. This keeps the marks 
visible when you rotate the sensor, as instructed in the next step. 

Figure 4.6: Extending the Marks for the ALS150

Extend both
lines down

✍

✍
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8. Rotate the sensor 180° and align the sensor with the four marks you made in the earlier 
steps, as shown in Figure 4.7. Be sure to line up all four marks, so that the rotated sensor 
is as close as possible to the same position it was in when you took the first calibration 
reading in Step 4. 

Figure 4.7: Rotate and Align the Sensor
9. Click Next to take the second calibration reading.

If the new calibration offsets are too large (> 0.5 degrees) for your ALS sensor to operate 
reliably, a dialog displays telling you to contact customer support at CyberOptics 
Semiconductor. Write down the Roll and Pitch offsets displayed in the dialog and click 
OK. For information on contacting customer support, see “Technical Support,” on 
page 2.6.

WAFERSENSE™ ALS150 WAFERSENSE™ ALS200
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If the new calibration offsets are within the allowed limits, the wizard displays the 4 of 4 
Finish Calibration dialog, as shown in Figure 4.8. 

Figure 4.8: 4 of 4 Finish Calibration Dialog
10. Click Save to save the new calibration values.

That completes the zero-point calibration.
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Specifications
System Requirements

To run the WaferSense ALS software and link, your computer must have:
• Windows 98 Second Edition, Windows 2000, Windows Me, or Windows XP 

operating system
• One free high-power USB 1.1 or USB 2.0 port

ALS Hardware
Environmental

Operating pressure range: High vacuum to atmospheric.

Storage temperature range: -20 °C to 60 °C.

Charging temperature range: 0 °C to 45 °C

Maximum operating temperature range: 10 °C to 60 °C.

Temperature range for specified inclination measurement repeatability: 20 °C to 30 °C.

Power
Battery usage on a full charge: approximately 6 hours.

Maximum battery recharge cycles: approximately 500.

Precision and Accuracy
Inclination precision: ± 0.003 degree over a range of -4° to +4° from absolute level for one year 
from date of last calibration.

Table 5.1 on page 5.2 shows the maximum and root-mean-square (rms) errors for ALS readings 
relative to absolute level using a sensor that has been factory calibrated within the last year. 
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Error values vary with the magnitude of the reading. Values are shown for readings of 0, ±2, 
and ±4 degrees. 

Table 5.2 shows the maximum and root-mean-square (rms) error for ALS readings relative to a 
user-specified reference plane (see “Specifying a Reference Plane,” on page 3.10) using a sensor 
that has been factory calibrated within the last year. 

 

Reading 
(degrees)

ALS150 and ALS200 ALS300
Max Error 
(degrees)

RMS Error 
(degrees)

Max Error 
(degrees)

RMS Error 
(degrees)

0 0.04 0.03 0.05 0.03
±2 0.10 0.07 0.11 0.07
±4 0.17 0.13 0.18 0.13

Table 5.1: Error for Absolute Measurements

Reading 
(degrees)

ALS150 and ALS200 ALS300
Max Error 
(degrees)

RMS Error 
(degrees)

Max Error 
(degrees)

RMS Error 
(degrees)

0 0.02 0.02 0.03 0.03

Table 5.2: Error for Relative Measurements
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